Pouvoir Accéder et Utiliser MATE/Gestionnaire de fichiers

Gestionnaire de fichiers


Modèle:Pouvoir Accéder et Utiliser MATE

Description du gestionnaire de fichiersModifier

Le gestionnaire de fichiers permet d’obtenir une vue d’ensemble des fichiers et des dossiers de votre ordinateur. Il présente les composants de votre ordinateur de façon hiérarchique.

Dans cette leçon, nous allons vous présenter les principales fonctions du gestionnaire de fichiers. La plupart d’entre elles vous sembleront proches de celles déjà étudiées dans d’autres contextes. Ce sera l’occasion pour vous de découvrir comment appliquer les connaissances acquises à des contextes différents.

Présentation et lancement du gestionnaire de fichiersModifier

Le gestionnaire de fichiers offre entre autres la possibilité de déplacer, de copier et de renommer, de supprimer ou de rechercher des fichiers. Avant de rappeler les éléments de la fenêtre d’application du gestionnaire de fichiers, nous vous proposons de faire un premier exercice qui consiste à le lancer par le chemin du dossier personnel.

Tout d’abord, assurez-vous d’être sur le bureau de MATE. À l’aide des flèches de direction, sélectionnez la commande Dossier personnel et ouvrez-le à l’aide de la touche entrée.

Vous pourrez également ouvrir le gestionnaire de fichiers à partir du menu Emplacement du menu principal ou de l’icône Caja du sous-menu Outils système situé dans le menu Applications du menu principal.

Nous allons maintenant vous expliquer la procédure pour lancer le gestionnaire de fichiers à partir du menu principal, en utilisant le point d'entrée du poste de travail. Tout d’abord, déroulez le menu principal à l’aide du raccourci alt-f1.

À l’aide de la flèche droite, sélectionnez le menu Emplacement et déroulez-le à l’aide de la flèche bas. Sélectionnez alors la commande Poste de travail et appuyez sur la touche entrée.

Notez que dans les deux procédures expliquées ci-dessus, vous auriez obtenu une fenêtre identique si vous aviez lancé le Poste de travail ou la Corbeille, voire le chemin vers un dossier ou un lecteur distant.

Le poste de travail vous permet d’accéder au contenu de tous les composants de votre ordinateur, comme une clé USB, les différentes parties du disque dur ou le lecteur de DVD. Le poste de travail est assez peu utile car les clés USB et DVDs insérés à votre ordinateur apparaissent sur votre bureau sous la forme d’icônes. Mais il peut être pratique d'accéder à certains fichiers de votre disque dur.

Le dossier personnel vous donne accès à l’ensemble des fichiers et dossiers que vous aurez créés et classés.

Les éléments de la fenêtre du gestionnaire de fichiersModifier

La fenêtre du gestionnaire de fichiers, appelé aussi Caja, devrait être affichée à l’écran. Si la fenêtre n’apparaît pas en plein écran, vous pouvez la maximiser. Pour ce faire, ouvrez le menu système par le raccourci clavier alt-barre d’espacement. Sélectionnez Maximiser à l’aide des flèches de direction puis appuyez sur entrée. Si la commande n’apparaît pas, c’est que la fenêtre est déjà maximisée. Pour refermer le menu système, appuyez sur échap.

La fenêtre du gestionnaire de fichiers étant une fenêtre d’application de MATE, elle présente une barre de menus où on trouve les menus Fichier, édition, afffichage, aller à, varoris et aide. Ces derniers offrent des commandes comme supprimer un document, créer un nouveau dossier et déplacer un document. Ces commandes sont communes à toutes les entrées dans le gestionnaire de fichiers dont le Poste de travail fait partie.

Si votre ordinateur a été installé par Hypra ou que la personne qui vous l'a fourni a séparé les données des fichiers de votre système, la fenêtre du poste de travail affiche :

  • un système de fichiers de quelques dizaines de gigaoctets, qui correspond à la partie de votre disque dur consacrée au système ;
  • un système de fichiers plus gros, variant selon la taille de votre disque dur, qui sert à stocker vos données ;
  • le lecteur de DVD ;
  • éventuellement, une clé USB, dont le nom varie selon la façon dont a été créée la clé USB.

Le premier système de fichiers n’est pas modifiable, sauf si vous entrez votre mot de passe administrateur. Il contient les fichiers nécessaires au fonctionnement de votre ordinateur. Vous ne devrez pas y toucher à ce stade, mais vous pouvez accéder à partir de ce chemin à votre dossier personnel et à vos clés USB. En effet, si vous ouvrez le système de fichiers, puis sélectionnez le dossier media, les sous-dossiers présents dans ce dossier correspondent à vos clés.

Toujours dans le système de fichiers, si vous ouvrez le dossier home, puis le dossier portant votre nom, vous arrivez dans votre dossier personnel. Ce n’est pas la solution d’accès la plus rapide, mais elle constitue le chemin de base.

La fenêtre du dossier personnel affiche le premier niveau de classement de vos fichiers et dossiers personnel. Par défaut, figurent des dossiers tels que Musique, Documents, Bureau, Téléchargements, etc.

Dans la fenêtre du gestionnaire de fichiers, les éléments de votre système peuvent être affichés sous différentes formes : en liste, en icônes, ou en liste compacte. La liste affiche le titre, les dates et la taille du fichier. La liste compacte affiche les éléments en liste mais sans les détails les concernant. Les icônes affichent les icônes de vos fichiers et dossiers répartis sur tout l'écran, de gauche à droite et de haut en bas. Ce mode d'affichage rend le parcours des fichiers et dossiers de votre ordinateur complexe pour les utilisateurs d'un lecteur d'écran.

Pour afficher les éléments sous forme de liste compacte, voici comment procéder. L’exercice qui suit vous permettra de faire en sorte que ce mode d’affichage s’applique à toutes les fenêtres du Poste de travail, y compris la corbeille, le dossier personnel, les clés USB, etc.

Tout d’abord, déroulez le menu Edition à l’aide des touches alt-d. Sélectionnez ensuite Préférences à l’aide de la flèche bas. Appuyez sur la touche entrée pour ouvrir la boîte de dialogue.

Maintenant, appuyez sur tab pour amener votre curseur sur le premier élément de la fiche Vues. C’est une liste déroulante vous permettant de choisir la vue pour tous nouveaux dossiers. À l’aide de la flèche bas, choisissez le mode liste ou liste compacte.

Si vous appuyez sur tab, une autre liste déroulante vous permet de définir l’ordre dans lequel sont présentés les éléments dans la fenêtre du gestionnaire de fichiers. Vous pouvez ainsi afficher les fichiers et dossiers en ordre alphabétique (par nom), par taille, par type, etc. choisissez votre mode de classement préféré.

À l’aide de la touche tab ou maj-tab, sélectionnez le bouton Fermer. Appuyez sur entrée pour refermer la boîte de dialogue.

Il vous faudra quitter puis rouvrir le poste de travail pour appliquer ces changements. Notez que par défaut, MATE affiche les éléments en liste compacte sur un ordinateur Hypra, en icônes sur un ordinateur classique.

Notez qu’au bas de la fenêtre, peut être affichée une barre d’état sur laquelle vous trouverez des informations telles que le nombre d’éléments contenus dans un objet sélectionné, l’espace occupé par cet élément et l’espace disponible sur cette partie du disque. Pour faire afficher la barre d’état, utilisez le menu Affichage.[1]

Vous avez vu les différents éléments de la fenêtre du gestionnaire de fichiers.

Système de classementModifier

Maintenant que vous avez étudié les éléments de la fenêtre du gestionnaire de fichiers, nous vous proposons d’effectuer des exercices afin de mieux comprendre son système de classement de fichiers.

La fenêtre du poste de travail doit être ouverte. Rappelez-vous que vous pouvez lancer cette application en passant par le menu principal. Pour plus d’informations, nous vous renvoyons à la leçon précédente.

Suite à l’ouverture du poste de travail, le curseur se trouve par défaut sur le premier élément de la liste. Pour explorer les différents éléments de votre ordinateur à partir du poste de travail, vous devez d’abord appuyer sur la touche flèche bas pour sélectionner le premier élément contenu dans la fenêtre. Puis, les flèches haut et bas vous permettent de parcourir la liste.

À partir du poste de travail, vous pouvez faire afficher le contenu d’un élément en le sélectionnant et en appuyant sur la touche entrée. Lorsque vous faites afficher le contenu d’un dossier sélectionné, le contenu de la fenêtre est mis à jour avec la liste des éléments du dossier. La barre de titre affiche le nom du dossier ou de l’emplacement dans lequel vous vous trouvez.[2]

Dans le gestionnaire de fichiers, chaque fenêtre affiche un dossier qui entre dans une hiérarchie de classement. Dans cette hiérarchie, le tout premier niveau de votre système est noté /. Il contient les fichiers de votre ordinateur, le dossier home qui mène à votre dossier personnel et le dossier media qui vous amène à vos appareils connectés à votre ordinateur. Tous ces éléments sont au second niveau.

À un troisième niveau, se trouvent les dossiers des utilisateurs, contenus dans /home, et vos appareils connectés contenus dans /media. Rappelez-vous que pour accéder plus rapidement à votre dossier personnel lorsque vous devez saisir cet élément comme emplacement, il est noté ~, que vous obtenez en appuyant sur la touche altgr et la touche correspondant au chiffre 2 ou é du clavier étendu.

Pour vous exercer, faites apparaître le contenu du système de fichiers le plus gros. Pour ce faire, utilisez la flèche haut ou la flèche bas pour sélectionner l’icône Système de fichiers inconnu avec la valeur la plus importante entre parenthèses. Puis, appuyez sur la touche entrée. Le contenu de la partition du disque dur réservée à vos données remplacera le contenu de votre poste de travail. Vous pourrez ainsi connaître tous les fichiers de votre partition en les explorant avec les flèches haut et bas. La même procédure s’applique si vous accédez au dossier personnel par l’icône du bureau, le menu principal ou le menu Aller à du gestionnaire de fichiers, qui sont les chemins que vous utiliserez le plus souvent en pratique.

Maintenant, vous pouvez revenir au contenu précédemment affiché en activant la commande Poste de travail du menu Aller à. Si vous appuyez sur la touche retour arrière ou backspace, vous atterrirez dans votre système de fichiers réservé à votre ordinateur, dans le dossier home.

Si un dossier est vide, la fenêtre du gestionnaire du fichiers reste vide. Appuyez sur retour arrière pour revenir au niveau précédent.

Vous avez donc remarqué que le précédent exercice vous a amené à parcourir des dossiers et des sous-dossiers. Une autre façon d’explorer les sous-dossiers est, en mode liste compacte, de dérouler les dossiers sur lesquels se trouve le curseur. Pour ce faire, vous appuuyez sur la flèche droite. Cela permet de dérouler la hiérarchie d’une autre manière, mais l'inconvénient est que le titre de la fenêtre ne change pas selon le dossier où vous vous trouvez. Nous vous déconseillons donc cette méthode.[3]

Si la liste des fichiers et dossiers d’une fenêtre est trop longue, vous pouvez utiliser les touches page suivante et page précédente pour faire défiler le contenu un écran à la fois.

Enfin, vous pouvez ouvrir un élément après l’avoir sélectionné avec les flèches de direction en appuyant sur la touche entrée. Dans le cas d’un dossier, le contenu va apparaître dans la fenêtre, remplaçant celui de la précédente fenêtre, et le titre de la fenêtre changera pour prendre le nom du dossier. Dans le cas d’un fichier, celui-ci sera ouvert avec l’application correspondante.

Quand vous connectez une clé USB, la fenêtre de son contenu s’ouvre automatiquement. Si vous la fermez, vous pouvez y retourner par le menu Emplacement ou l'icône que votre ordinateur a automatiquement ajoutée sur votre bureau portant le nom associé à votre clé USB. C’est également ici que vous pourrez, avant d’enlever votre clé, l’indiquer à MATE. Pour ce faire, vous sélectionnez la clé, vous ouvrez le menu contextuel à l’aide des touches maj-f10, et vous choisissez Éjecter, ou Démonter ou Retirer sans risque. Quand vous avez activé une de ces commandes, l’icône de la clé disparaît et vous pouvez la débrancher. Il est important de toujours suivre cette procédure, sinon vous pourriez dégrader votre clé ou son contenu.

Enfin, il est important de noter que selon l’élément sélectionné, certaines commandes du menu de la fenêtre ne sont pas offertes parce qu’elles ne s’appliquent pas. On dit que ces commandes sont inactives. Ainsi, les commandes Supprimer un document et renommer ne seront pas présentes si votre système de fichiers est sélectionné.

Ouverture d’un documentModifier

Dans cette leçon, vous allez apprendre à lancer un ou plusieurs documents à partir du gestionnaire de fichiers.

Le lancement d’un documentModifier

Dans cet exercice, vous allez ouvrir un document de type OpenDocument, lu par Writer. Assurez-vous d’abord que le gestionnaire de fichiers est bien ouvert dans la racine de votre dossier personnel. Ensuite, sélectionnez le dossier Documents à l’aide des flèches de direction. Appuyez sur entrée pour l’ouvrir.

La fenêtre devrait s’intituler maintenant Documents. À l’aide des flèches haut et bas, sélectionnez le document portant votre nom de famille.[3]

Maintenant que le document portant votre nom de famille pour titre est sélectionné, ouvrez-le en appuyant sur entrée.

Dès que vous commandez l’ouverture du document portant votre nom de famille pour titre, MATE lance l’application Writer. La fenêtre d’application Writer devient alors celle active et elle s’affiche donc devant celle du gestionnaire de fichiers. Avant de poursuivre, refermez la fenêtre Writer en appuyant sur les touches alt-f4.

La sélection de plusieurs documentsModifier

La fenêtre du gestionnaire de fichiers devrait être affichée à l’écran et le curseur devrait se trouver sur le document portant votre nom de famille pour titre. À partir du gestionnaire de fichiers, vous pouvez également lancer plusieurs documents de façon simultanée. Pour ce faire, vous sélectionnez les documents que vous désirez ouvrir et vous appuyez sur entrée. Vous allez maintenant apprendre à ouvrir plusieurs fichiers à partir du gestionnaire de fichiers.

Nous allons commencer par vous indiquer comment sélectionner plusieurs documents qui se suivent. Cette procédure ressemble à celle qu’on utilise pour sélectionner une phrase dans un texte. Vous positionnez le curseur sur le premier élément de la liste que vous désirez sélectionner. Vous appuyez ensuite sur la touche maj et en la maintenant enfoncée, vous appuyez sur la flèche haut ou bas. Lorsque vous avez sélectionné les éléments de votre choix, vous relâchez les touches. Sélectionnez plusieurs éléments en suivant cette procédure.

Plusieurs éléments devraient être sélectionnés. Vous pouvez vérifier quels éléments ont été sélectionnés en utilisant votre aide technique pour lire la barre d'état.[1] Désactivez ensuite votre sélection en appuyant sur les flèches de direction.

Pour sélectionner plusieurs fichiers qui ne se suivent pas, vous devez positionner votre curseur sur le premier fichier de votre choix à l’aide de la flèche bas ou haut. Ensuite, en maintenant la touche ctrl enfoncée, utilisez les flèches haut et bas pour positionner le curseur sur le prochain fichier de votre choix et appuyez sur la barre d’espacement pour le sélectionner. Tant que la touche ctrl est enfoncée, vous pouvez déplacer le curseur avec les flèches de direction et sélectionner des fichiers.

Plusieurs éléments devraient être sélectionnés. Vous pouvez vérifier quels éléments ont été sélectionnés en utilisant votre aide technique pour lire la barre d'état.[1].

à partir de ce moment, vous pourriez les ouvrir en appuyant sur entrée. Pour le moment, désactivez les sélections en appuyant sur une flèche de direction.

Les procédures que vous venez d’apprendre pour sélectionner des éléments peuvent également être utiles pour supprimer, copier, ou déplacer plusieurs éléments d’un seul coup. Vous verrez comment effectuer ces opérations dans les prochaines leçons.

Gestion des fichiers et dossiersModifier

Comme nous l’avons déjà mentionné, le gestionnaire de fichiers constitue un système de classement de fichiers et sa principale unité de rangement est le dossier. Cette leçon vous permetra d’apprendre à créer des dossiers pour ranger et catégoriser vos fichiers. Par la suite, vous verrez comment supprimer, renommer et obtenir des informations sur les propriétés de vos fichiers. Ces trois fonctions s’appliquent aussi à vos dossiers.

La création d’un dossierModifier

Pour effectuer les exercices de cette leçon, assurez-vous que le gestionnaire de fichiers est bien ouvert dans votre dossier personnel.

Maintenant, sélectionnez le dossier Documents à l’aide des flèches de direction et appuyez sur entrée pour l’ouvrir.

Déroulez maintenant le menu Fichier en appuyant sur les touches alt-f. Dans ce menu, sélectionnez la commande Créer un dossier à l’aide de la flèche bas et appuyez sur entrée pour ouvrir la boîte de dialogue. Vous pouvez également ouvrir cette boîte de dialogue depuis votre fenêtre principale du dossier personnel en utilisant le raccourci ctrl-maj-n.

Lorsque vous passez cette commande, un nouveau dossier intitulé Nouveau dossier apparaît dans la liste des fichiers et des dossiers. Le curseur se trouve dans la zone de saisie du nom du nouveau dossier. Vous pouvez aussitôt taper le nom que vous voulez donner au dossier et appuyer sur entrée.

Vous devriez avoir créé un dossier où vous pourrez classer vos documents. Vérifiez le résultat en parcourant la liste avec les flèches de direction.

La suppression d’un fichier ou d’un dossierModifier

Dans le gestionnaire de fichiers, vous pouvez supprimer des fichiers et des dossiers. Vous allez maintenant supprimer le dossier que vous venez de créer. Pour ce faire, commencez par le sélectionner.[1]

Pour supprimer votre dossier sélectionné, faites dérouler le menu Edition à l’aide des touches alt-d. Sélectionnez la commande Mettre à la corbeille avec la flèche bas et appuyez sur entrée. Vous pouvez également utiliser la touche Supprimer du clavier sans passer par le menu.

Maintenant, une boîte de message devrait être affichée. Elle vous demande si vous désirez envoyer le dossier sélectionné à la corbeille. Appuyez sur entrée pour confirmer. Votre curseur se trouve sur ce bouton par défaut. Pour annuler l’opération, tapez simplement sur la touche échap.

Vous pouvez également supprimer le fichier ou le dossier définitivement sans le placer dans la corbeille en le sélectionnant et en appuyant ensuite sur maj-supprimer. Notez que lorsqu’un élément se trouve dans la corbeille, vous pouvez toujours le récupérer en appliquant la procédure de restauration du menu Edition, ou bien en faisant un copier-coller vers un dossier de votre choix. Remarquez que le raccourci ctrl-z a également pour effet, dans le gestionnaire de fichiers, de restaurer un élément que vous avez mis à la corbeille.

Attention : lorsque vous supprimez un fichier sur une clé USB, celui-ci ne sera pas placé dans la corbeille. Il sera supprimé définitivement, après vous en avoir averti, peu importe la commande que vous utilisez.

Le changement de nom d’un fichier ou d’un dossierModifier

Dans le gestionnaire de fichiers, vous pouvez renommer un fichier ou un dossier. Nous vous proposons de faire l’exercice suivant qui consiste à changer le nom d’un fichier.

Tout d’abord, sélectionnez le fichier portant votre prénom comme titre avec les flèches de direction ou en tapant les premières lettres de son titre puis appuyez sur échap.

Maintenant que le fichier portant votre prénom pour titre est sélectionné, faites dérouler le menu Edition en appuyant sur alt-d, sélectionnez la commande Renommer à l’aide des flèches de direction et appuyez sur entrée.

Une fois que vous avez passé la commande Renommer, le curseur se trouve par défaut dans la zone de saisie du nom du fichier. Vous pouvez aussitôt taper un nom. Pour cet exercice, tapez le nom Exercice. Ne supprimez pas l’extension après le point qui indique au gestionnaire de fichiers avec quel programme ouvrir le document. Appuyez ensuite sur la touche Entrée.

Notez que le raccourci de la commande Renommer est f2. Vous pouvez également renommer un dossier ou une icône sur le bureau de la même façon.

L’information sur les propriétésModifier

Dans le gestionnaire de fichiers, vous pouvez également obtenir de l’information sur les propriétés d’un fichier, d’un dossier, ou même d’une partition de disque. Pour consulter les propriétés, sélectionnez d’abord un dossier de votre choix. Ensuite, faites dérouler le menu Fichier, sélectionnez la commande Propriétés et appuyez sur la touche entrée. La boîte de dialogue Propriétés s’affichera. Vous pouvez également obtenir ce résultat en appuyant sur le raccourci alt-entrée.

La boîte de dialogue Propriétés du dossier sélectionné devrait être affichée. Cette boîte comporte quatre fiches superposées : Général, emblèmes, permissions et notes.

Par défaut, vous vous trouverez sur la fiche Général. Cette fiche vous informe d’abord sur le nom et le type d’élément dont il s’agit. Elle présente également son chemin d’accès, sa taille et le nombre d'éléments (dossiers et fichiers) que ce dossier contient. Vous pouvez accéder à ces éléments avec la touche tab ou avec le curseur d’exploration de votre aide technique.[4]

La fiche Permissions comporte quatre groupes d’options contenues dans des listes déroulantes. Le premier groupe définit la personne propriétaire d’un fichier ou dossier et les droits que cela lui donne. Par défaut, le propriétaire est votre nom d’utilisateur, donc vous-même. Vous avez bien sûr le droit de lire le dossier et de le modifier.

Pour modifier ces valeurs, placez le curseur dans la zone de saisie et tapez un nouveau nom d’utilisateur. S’il vous convient, appuyez sur tab et, à l’aide de la flèche bas, sélectionnez les droits que vous souhaitez acquérir ou perdre. Par exemple, vous pourriez décider de rendre ce fichier non modifiable et uniquement lisible. De même, si ce fichier est un exécutable, vous devez vous donner explicitement les droits d’exécution.

Le deuxième groupe d’options vous permet de définir à quel groupe de personnes appartient le fichier ou le dossier. Par défaut, le groupe correspond également à votre nom d’utilisateur. Ce groupe pourrait contenir d’autres personnes qui utilisent cet ordinateur et auxquelles vous pourriez souhaiter donner des droits d’accès spéciaux à vos fichiers. La même liste déroulante vous permet de donner les droits souhaités aux autres personnes du groupe.

Le troisième groupe d’options vous permet de décider des droits attribués aux utilisateurs qui ne sont ni propriétaires du fichier, ni membres du groupe auquel appartient le fichier. Il fonctionne par une simple liste déroulante.

Nous vous conseillons de ne pas vous atarder sur le quatrième groupe d’options. Il permet, par des cases à cocher, de donner au fichier des attributs complémentaires. Il est peu probable que vous en ayez besoin.

Comme dans toute boîte de dialogue, vous passez d’un onglet à l’autre en vous positionnant sur le titre de l’onglet et en utilisant les flèches gauche et droite. Pour passer d’un élément à l’autre dans une fiche, vous appuyez sur la touche tab. Pour confirmer vos choix, vous appuyez sur entrée.

Remarquez que le contenu de la boîte de dialogue, notamment de la fiche général, varie selon l’élément sélectionné dans le gestionnaire de fichiers.[5]

Copier et déplacer des fichiersModifier

Dans le gestionnaire de fichiers, vous pouvez copier un fichier à différents endroits ou encore le déplacer. Dans cette leçon, vous ferez des exercices pour copier ou déplacer des fichiers. Notez que les procédures que vous verrez s’appliquent aussi à des dossiers. Pour suivre l’exercice, assurez-vous que le gestionnaire de fichiers est ouvert.

La copie d’un fichierModifier

Lorsque vous écrivez un texte à l’ordinateur, il est conseillé de faire des copies de sauvegarde pour des raisons de sécurité. Nous allons maintenant vous guider dans un exercice qui consiste à copier un fichier.

Tout d’abord, vous devez choisir un fichier. À cette fin, sélectionnez le dossier Documents dans votre dossier personnel et, à l’intérieur, sélectionnez le fichier portant votre nom pour titre. En cas de besoin, référez-vous à la leçon 3 de ce module.

Maintenant que vous avez sélectionné un fichier, vous allez en faire une copie dans le presse-papiers. Pour copier le fichier, utilisez le raccourci ctrl-c ou la commande Copier du menu Edition.

Le fichier est maintenant en mémoire. Vous allez revenir à la racine du dossier personnel, dans laquelle cette copie sera déposée. Pour ce faire, appuyez sur la touche retour arrière.

Maintenant que vous êtes à la racine du dossier personnel, vous allez déposer la copie du fichier en passant la commande Coller. Pour ce faire, utilisez le raccourci ctrl-v ou la commande Coller du menu Edition.

Vous pouvez vérifier que la copie du fichier se trouve bien dans le contenu du dossier personnel.

Le déplacement d’un fichierModifier

Dans le gestionnaire de fichiers, vous pouvez également déplacer un fichier. Pour ce faire, vous passez les commandes Couper et Coller plutôt que les commandes Copier et Coller.

Lorsque vous passez la commande Couper, le fichier est copié dans le presse-papiers. Il ne sera retiré du dossier d’origine qu’une fois que vous aurez passé la commande Coller. Le raccourci de la commande Couper est ctrl-x, poursuivi de la commande Coller ctrl-v.

Vous pouvez faire l’exercice de couper le fichier portant le nom Exercices, contenu dans le dossier Documents, pour le coller dans la racine du dossier personnel. Vous pourrez vérifier si le fichier a bien été déplacé en consultant les fichiers du dossier Documents après y être retourné.

Création d’un raccourciModifier

À partir du gestionnaire de fichiers, vous pouvez créer des icônes de raccourci. On utilise généralement des raccourcis pour rendre une application, un dossier ou un document plus faciles d’accès. On les retrouve par exemple sur le bureau. Notez que l’icône de raccourci représente l’éléments auquel elle est associée sans toutefois le remplacer ni le copier.

La sélection de l’emplacement du raccourciModifier

Dans l’exercice qui suit, vous allez disposer sur le bureau une icône de raccourci pour le document portant votre nom pour titre. À la leçon 4 du module 5 intitulé Configuration du système, vous apprendrez à créer un raccourci dans le menu principal. Assurez-vous que le gestionnaire de fichiers soit bien ouvert, sinon lancez-le en ouvrant le dossier personnel depuis le bureau ou le menu principal.

Dans votre dossier personnel, sélectionnez le dossier intitulé Bureau. Ce dossier, que vous avez le droit de supprimer, contient tous les raccourcis personnalisés sur votre bureau. Nous vous recommandons donc de le laisser en l’état. Appuyez sur entrée pour l’ouvrir.

La sélection de l’élément faisant l’objet du raccourciModifier

Maintenant que vous avez sélectionné l’endroit où créer le raccourci, ouvrez une seconde fenêtre du gestionnaire de fichiers. Pour ce faire, faites dérouler le menu Fichier à l’aide des touches alt-f et choisissez Nouvelle fenêtre. Une nouvelle fenêtre apparaît.

Pour vous assurer que vous êtes à la racine du dossier personnel, utilisez un raccourci qui vous y ramène systématiquement, il s’agit de alt-début.

Maintenant, sélectionnez le dossier Documents et ouvrez-le à l’aide de la touche entrée.

Enfin, sélectionnez le fichier portant pour titre votre nom de famille.

Maintenant, déroulez le menu Edition à l’aide des touches alt-d. À l’aide de la flèche bas, sélectionnez la commande Créer un lien. Appuyez sur entrée, le menu se referme et vous retournez dans la fenêtre intitulée Documents.

Dans la fenêtre Documents, sélectionnez l'intitulé qui vient de se créer Lien vers votre nom de famille. Il s’agit de votre raccourci proprement dit. Déplacez-le sur le bureau avec la séquence ctrl-x, alt-tab et ctrl-v.

Le nom du raccourciModifier

La fenêtre du dossier Bureau devrait être ouverte à l’écran. Placez le curseur sur l’élément intitulé lien de votre nom de famille. Pour renommer cette icône, utilisez la commande Renommer du menu Edition telle qu’on l’a étudiée à la leçon 4. Vous pouvez par exemple donner à cette icône le même nom que le fichier d’origine. Rappelez-vous cependant que si vous supprimez par la suite ce raccourci, le fichier d’origine sera conservé dans son emplacement d’origine.

Vous pouvez vérifier si l’icône de raccourci a bien été créée sur le bureau. Pour ce faire, appuyez sur alt-ctrl-d et explorez les icônes du bureau. Le raccourci que vous venez de créer devrait apparaître.

Associer une touche de raccourci à une icône d’applicationModifier

Il est possible d’attribuer un raccourci à une icône permettant de lancer une application, voire d'ouvrir un document. Lorsque vous utilisez le raccourci clavier, cela ouvre directement l’application. Vous allez maintenant attribuer un raccourci à l’icône Writer.

Pour ce faire, déroulez le menu principal à l’aide des touches alt-f1. Rendez-vous dans le menu Système à l’aide de la flèche gauche et déroulez le sous-menu des préférences à l’aide de la flèche droite. Choisissez ensuite la commande Matériel et déroulez son sous-menu. Enfin, sélectionnez la commande Raccourcis et appuyez sur entrée pour ouvrir la boîte de dialogue.

Nous allons maintenant ajouter une commande de lancement de Writer. Pour ce faire, sélectionnez le bouton Ajouter avec la touche tab. Une nouvelle boîte de dialogue apparaît.

Dans la zone de saisie Nom, entrez un nom pour vous permettre d’identifier à quoi correspond la commande en question. Puis, appuyez sur tab deux fois et demandez à voir les applications actuellement installées sur votre ordinateur à l’aide du bouton Parcourir.

La boîte de dialogue Applications disponibles devrait être ouverte. Dans la liste, choisissez LibreOffice4.2 Writer. Appuyez sur Entrée pour confirmer ce choix.

Maintenant, confirmez vos choix en sélectionnant le bouton Appliquer de la boîte de dialogue à l’aide de la touche tab.

Vous êtes de retour dans la boîte de dialogue Raccourcis. À l'aide des touches maj-tab, que vous pressez deux fois, vous revenez à la liste des programmes disponibles. Appuyez sur la touche fin pour positionner le curseur sur son dernier élément, correspondant à celui que vous venez de créer. La ligne se présente sous forme de deux colonnes. À gauche, se trouve le nom de la commande. Pour la modifier, vous appuyez sur entrée.

Si vous appuyez sur flèche droite, vous atteignez la colonne de droite où vous allez inscrire le raccourci clavier. Pour passer en mode saisie, appuyez sur la barre d’espacement. Saisissez maintenant le raccourci alt-ctrl-w. Ce sera le raccourci pour lancer Writer.

Pour le modifier, il vous suffira de suivre les mêmes étapes : retrouver la commande, déplacer le curseur dans la colonne de droite, l’éditer et entrer le nouveau raccourci.

Appuyez enfin sur tab pour atteindre le bouton Fermer et activez-le à l’aide de la touche entrée.

Maintenant, vérifiez que le raccourci clavier fonctionne bien. Appuyez sur le raccourci clavier alt-ctrl-w. Ceci devrait lancer l’application Writer.

Vous pouvez maintenant refermer le document et son application en appuyant sur alt-f4. Puis, retournez dans le gestionnaire de fichiers à l’aide des touches alt-tab.

Notez qu’un raccourci clavier s’utilise à partir de n’importe quelle fenêtre. Il peut lancer tout type de commande, y compris l'ouverture d’un document, quel que soit son emplacement, si la commande qu'il lance ouvre l'application choisie sur un document donné.

La suppression d’un raccourciModifier

Notez que vous pouvez modifier un raccourci sans pour autant modifier le fichier d’origine qu’il représente. Pour ce faire, vous sélectionnez le raccourci et vous appuyez sur la touche supprimer. Une boîte de message apparaît pour vous demander si vous voulez envoyer un raccourci à la corbeille. Vous devez alors appuyer sur entrée pour confirmer la commande.

Pour vérifier si un élément est un raccourci ou un fichier d’origine, vous pouvez activer la boîte de dialogue Propriétés où la fiche Général vous informe sur le type de l’élément.

Cette leçon est terminée. Vous pouvez refermer le gestionnaire de fichiers et les deux fenêtres que nous avons ouvertes, à l’aide des touches alt-f4. Dans la prochaine leçon, nous étudierons un autre outil qui permet de rechercher des éléments enregistrés sur votre ordinateur.

RechercherModifier

Avec MATE, vous pouvez retrouver les documents et les dossiers sauvegardés dans votre système grâce à l’outil de recherche. Dans cette leçon, vous verrez comment utiliser cette fonction de recherche.

Lancement de l’outil de rechercheModifier

Votre curseur devrait se trouver sur le bureau de MATE. Pour lancer l’outil de recherche, faites dérouler le menu principal à l’aide des touches alt-f1. À l’aide de la flèche bas, sélectionnez la commande Accessoires et déroulez son sous-menu à l’aide de la flèche droite.

Maintenant, à l’aide de la flèche bas, sélectionnez la commande Rechercher des fichiers. Lancez-la avec la touche Entrée.

Les éléments de la fenêtre Recherche de fichiersModifier

La fenêtre de recherche de fichiers devrait être affichée à l’écran. Si elle n’apparaît pas en plein écran, vous pouvez la maximiser. Pour ce faire, ouvrez le menu système par le raccourci clavier alt-barre d’espacement. Sélectionnez la commande Maximiser à l’aide de la flèche bas. Si la commande n’apparaît pas, c’est que la fenêtre d’application est déjà en plein écran. Dans ce cas, appuyez sur échap pour refermer le menu système.

Il s’agit ici d’une simple boîte de dialogue. Vous vous y déplacez donc à l’aide de la touche tab et vous utilisez les flèches haut et bas pour choisir des éléments d’une liste déroulante.

Par défaut, le curseur est amené, à l’ouverture, dans la zone de saisie Le nom contient. À côté de cette zone de saisie, une liste déroulante vous permet de choisir un élément que vous avez déjà recherché dans l’historique de vos recherches. Une liste déroulante vous permet de sélectionner le périmètre de votre recherche. En bas de la boîte de dialogue, vous retrouvez les boutons classiques Aide, Fermer et Rechercher.

Enfin, un bouton se trouve en bas de la boîte de dialogue et se présente sous la forme d’une case à cocher. Il est décoché par défaut. Si vous le cochez, avec la touche barre d’espacement, vous faites apparaître dans la boîte de dialogue des critères supplémentaires. Vous pourrez même en ajouter d’autres à partir du dernier bouton de la boîte de dialogue, une fois celle-ci entièrement déroulée.

Enfin, une fois que vous avez lancé une recherche, apparaît une section où sont inscrits, sous forme de liste, tous les fichiers trouvés et une barre d’état dans le bas.

La boîte de dialogue de baseModifier

Avant que vous ne cochiez le bouton vu plus haut, la boîte de dialogue vous permet de faire une recherche basée sur le nom du fichier et son emplacement. Par défaut, le curseur se trouve dans la zone de saisie Le nom contient. L’emplacement sélectionné par défaut est votre dossier personnel, c’est-à-dire que la recherche s’effectuera parmi tous les fichiers et dossiers contenus dans votre dossier personnel. Pour faire la recherche sur une clé USB, ou la limiter à un sous-dossier de votre dossier personnel, appuyez sur tab jusqu’à ce que vous arriviez à la zone Emplacement. Ouvrez la liste déroulante à l’aide de la flèche bas.

Plusieurs possibilités vous sont proposées par défaut. Parmi les choix, se trouve peut-être le nom de votre clé USB. Si ce n’est pas le cas, ou si vous souhaitez rechercher dans un sous-dossier de votre dossier personnel, sélectionnez le choix Autre et appuyez sur flèche bas. L’avantage de limiter la recherche à un sous-dossier est de l’accélérer et de limiter le nombre de résultats.

Vous avez peut-être remarqué que Autre était suivi de points de suspension. Comme vous l’avez appris au module 1, cela veut dire que ce choix ouvre une boîte de dialogue.

La navigation dans cette boîte de dialogue peut être quelque peu complexe. Nous vous proposons donc de saisir le nom du sous-dossier manuellement, comme nous l’avons fait pour ouvrir un fichier dans Writer. Pour cet exercice, appuyez sur les touches ctrl-l pour amener votre curseur à la zone de saisie Emplacement. C’est ici que vous allez inscrire l’emplacement auquel vous souhaitez limiter la recherche.

Si vous connaissez le chemin d’accès au sous-dossier, inscrivez-le. Par exemple, ~/Documents. Remarquez que quand vous saisissez les premières lettres du mot, MATE les complète automatiquement. S’il a identifié un dossier avant que vous n’ayez fini de taper son nom, il inscrira automatiquement la / à la fin de la zone. Appuyez alors sur flèche droite pour accepter cette suggestion, et inscrivez le sous-dossier.

Si vous recherchez votre fichier ou dossier sur une clé USB, inscrivez /media. Un appui sur la flèche droite fera apparaître le nom de votre clé. Si plusieurs clés USB sont branchées à votre ordinateur, tapez entrée puis flèche bas.

Maintenant, réouvrez la boîte de dialogue en réouvrant le choix Autre. Si vous appuyez alors sur la flèche bas, vous trouvez la liste des clés du dossier /media. Appuyez sur entrée pour en choisir une.

Maintenant, positionnez le curseur dans la zone de saisie Le nom contient avec les touches maj-tab deux fois, et inscrivez un nom de fichier, par exemple votre nom de famille, puis appuyez sur la touche Entrée pour que MATE fasse la recherche des fichiers et dossiers contenant votre nom de famille dans leur intitulé. Les résultats de la recherche seront affichés dans la section du bas de la fenêtre et le curseur se trouvera sur le bouton Arrêter. Appuyez sur tab pour lire le nombre de résultats obtenus et sur tab de nouveau pour accéder à la liste.

Vous pouvez consulter la liste des fichiers à l’aide de la flèche bas et les ouvrir en appuyant sur entrée. Nous vous conseillons de ne pas ouvrir de fenêtre pour le moment. Si vous appuyez sur les flèches gauche et droite, vous accéderez à des informations supplémentaires sur le fichier, telles que son emplacement sur votre système, la taille, le type et sa date de dernière modification.

Quand aucun fichier n’est retracé, une barre d’état située en bas de la fenêtre indique « 0 fichier trouvé ».[1] Si cette barre n’affiche pas cette information, une autre barre se trouve à côté de la zone des résultats et vous est accessible avec la touche tab. Si aucune de ces deux options ne vous apporte d’information, la façon de savoir si vos fichiers ont été trouvés est d’appuyer sur la touche flèche bas une fois dans la zone des résultats. Si aucune information ne vous est transmise, c’est que la liste au bas de la fenêtre ne contient aucun fichier. Dans ce cas, recommencez votre recherche avec un nom de fichier différent. Pour cela, déplacez votre curseur dans la zone de saisie Le nom contient avec la touche tab.

Préciser la périodeModifier

Vous pouvez également effectuer une recherche plus précise en utilisant d’autres critères de recherche développés lorsque vous cochez le bouton Sélectionner plus d’options. Cochez ce bouton, puis appuyez trois fois sur la touche tab pour saisir une période durant laquelle vos fichiers ont été modifiés.

Votre curseur se trouve maintenant sur la zone « Date inférieure à ». Il s’agit ici de définir le nombre de jours précédant la recherche et incluant la date à laquelle le fichier a été modifié pour la dernière fois. Dit autrement, vous indiquez ici il y a combien de jours au moins vous estimez que les fichiers que vous recherchez ont pu faire l’objet de modifications. La valeur par défaut est de 0. Saisissez un chiffre ou utilisez flèche haut pour modifier celui-ci.

Passez maintenant dans la seconde zone de saisie pour inscrire le nombre de jours maximal dans le lapse de temps où a été modifié le fichier. Dit autrement, vous indiquez ici il y a combien de jours au maximum vous estimez que les fichiers que vous recherchez ont pu faire l’objet de modifications. La valeur par défaut est de 0. La valeur que vous saisirez doit donc être supérieure à celle précédente.

Le bouton Rechercher étant sélectionné par défaut, appuyez ensuite sur la touche entrée pour lancer la recherche. MATE effectuera la recherche dans le périmètre sélectionné au préalable, comportant votre nom de famille et modifié depuis une période entre x et y jours, selon les valeurs que vous avez spécifiées. Après quelques instants, les résultats seront affichés dans le bas de la fenêtre d’application Outil de recherche. Vous pouvez consulter les résultats à l’aide de la touche tab et de la flèche bas.

Si vous ne spécifiez qu’un des deux nombre de jours et supprimez l’un des deux critères à l’aide du bouton situé à sa droite et accessible avec tab, la recherche sera moins précise et englobera tous les fichiers modifiés depuis x jours.

Pour explorer les autres critères de recherche, utilisez les touches tab qui font se succéder des zones de saisie, avec à leur droite un bouton pour supprimer le critère. Si la zone de saisie est vide, le critère n’est pas pris en compte.

Le bouton intitulé Ajouter une action de recherche, dans la boîte de dialogue déroulée, permet d’accéder à des critères et des actions avancés. Ils sont trop avancés à votre stade. Par contre, d’ores et déjà, vous pouvez définir dans la boîte de dialogue déroulée la taille du fichier recherché, de la même façon que la période de sa dernière modification que vous avez pratiquée plus haut. Explorez le reste de la boîte de dialogue.[6]

Ceci termine les leçons sur le gestionnaire de fichiers. Refermez toutes les fenêtres d’application à l’aide des touches alt-f4.

Questions et réponsesModifier

Cette leçon propose un quiz de cinq questions à choix multiples. Les réponses sont dans la section Réponses au quiz. Pour plus d'interaction, se trouve dans cette zone la raison pour laquelle les autres réponses ne sont pas correctes.

Questions à choix multiplesModifier

  1. Quels fichiers et dossiers s’affichent lorsque vous ouvrez le gestionnaire de fichiers à partir de l’icône Dossier personnel du bureau ?
    1. Les fichiers et dossiers de la corbeille
    2. Les fichiers et dossiers du poste de travail
    3. Les fichiers et dossiers de votre dossier personnel
    4. Les icônes du bureau
  2. Dans le gestionnaire de fichiers, quelle touche devez-vous utiliser pour remonter d’un niveau hiérarchique dans le classement des fichiers et dossiers ?
    1. alt-f4
    2. La touche retour arrière
    3. La touche échap
    4. La touche entrée
  3. Parmi les éléments suivants, lesquels ne s’affichent pas si votre gestionnaire des fichiers affiche une liste compacte ?
    1. Le nom du fichier
    2. L’extension du fichier
    3. Son emplacement
    4. Sa taille et sa date de modification
  4. Quel est le raccourci clavier qui permet de supprimer un élément sans le mettre à la corbeille ?
    1. supprimer
    2. maj-supprimer
    3. retour arrière
    4. ctrl
  5. Quel est le raccourci clavier qui permet de renommer un élément ?
    1. f2
    2. f1
    3. maj-f10
    4. alt-f4

Réponses au quizModifier

  1. Réponse 3, les icônes du bureau se trouvant dans le sous-dossier Bureau du dossier personnel. Les contenus du poste de travail et de la corbeille sont accessibles à partir de leurs icônes respectives.
  2. Réponse 2, la touche entrée permettant de descendre d’un niveau hiérarchique ou d’ouvrir un fichier.
  3. Réponse 4. L’emplacement ne s’affiche jamais sauf dans les propriétés de l’élément.
  4. Réponse 2. supprimer place le fichier dans la corbeille, et retour arrière remonte d’un niveau hiérarchique dans votre classement.
  5. Réponse 1. f1 permet d’ouvrir l’aide générale de MATE et maj-f10 le menu contextuel associé à un élément.

Notes et référencesModifier

  1. 1,0 1,1 1,2 1,3 et 1,4 insertion-page suivante deux fois rapidement : permet d’obtenir l’information présentée sur la dernière ligne d’une fenêtre. Par exemple, cette commande permet de présenter les informations affichées sur la barre d’état d’une application lorsque celle-ci est affichée.
  2. insertion-page suivante : permet d’obtenir le titre de la fenêtre d’application. Cette commande permet de lire le titre de l’application dans laquelle vous vous trouvez et le nom du document dans lequel vous travaillez. Notez que dans une boîte de dialogue, cette commande vous permet également de lire le titre de la boîte ou de l’onglet ou de la fiche active.
  3. 3,0 et 3,1 entrée du pavé numérique deux fois : permet d’obtenir des informations sur un objet sélectionné. Cette commande permet d’obtenir des informations sur un objet telles que son nom, sa nature et sa position dans la fenêtre (par exemple, ligne du tableau, etc).
  4. 7 et 9 du pavé numérique : déplacent le curseur de balayage dans une fenêtre. Cette commande déplace le curseur d’exploration de ligne en ligne dans n’importe quelle fenêtre, dont la boîte de dialogue.
  5. entrée du pavé numérique deux fois rapidement : permet d’obtenir des informations sur les options d’une boîte de dialogue. Cette commande permet d’obtenir de l’information sur les différentes options que l’on retrouve dans une boîte de dialogue et ce, dans l’ordre dans lequel elles sont présentées lorsqu’on se déplace avec la touche tab.
  6. Erreur de référence : Balise <ref> incorrecte : aucun texte n’a été fourni pour les références nommées orca20