Pouvoir Accéder et Utiliser MATE/Configuration de votre système

Configuration de votre système


Modèle:Pouvoir Accéder et Utiliser MATE

Description du menu SystèmeModifier

Le menu Système de MATE sert à régler les paramètres de votre ordinateur. Il permet entre autres de modifier les couleurs, les contrastes et la taille des caractères.

Dans cette leçon, nous allons vous présenter les sections importantes de ce menu et leur contenu. Nous les explorerons au fur et à mesure du présent module.

La section AdministrationModifier

La copie d'écran ci-contre vous présente l’apparence de ce menu une fois déroulé. Reportez-vous à la page 10 du guide tactile ou branchez le module tactile si vous êtes non voyant.

le menu Administration

Pour ouvrir la section Administration, déroulez d’abord le menu principal à l’aide des touches alt-f1. Puis, à l’aide de la flèche gauche, sélectionnez le menu Système.

Ce menu comporte plusieurs options dont nous avons déjà vu certaines dans ce cours. Pour cet exercice, sélectionnez l’icône Administration à l’aide des flèches haut et bas. Déroulez le sous-menu à l’aide de la flèche bas.

Voici les différents paramètres que vous pouvez régler en utilisant ce menu. Nous vous suggérons de les parcourir avec les flèches de direction, mais de n’en ouvrir aucun pour l’instant. Les commandes peuvent varier en fonction du système instalé sur votre ordinateur.

Ces icônes servent à ouvrir des fenêtres d’applications ou des boîtes de dialogue qui vous permettent, par exemple, d’installer des programmes.

Parmi les réglages possibles, se trouvent :

  • la date et l’heure de votre ordinateur ;
  • les imprimantes installées sur votre ordinateur ;
  • les utilisateurs ou profils enregistrés sur votre ordinateur ;
  • les logiciels installés sur votre ordinateur.

Le menu PréférencesModifier

La copie ci-contre vous présente l’apparence de ce menu une fois déroulé. Reportez-vous à la page 11 du guide tactile ou branchez le module tactile si vous êtes non voyant. Vous noterez qu’il comporte essentiellement d’autres icônes qu’il vous faudra dérouler.

le menu Préférences

Le menu Préférences se distingue de celui Administration par le fait que tous les réglages que vous y effectuerez n’affecteront que votre profil. Ils ne toucheront pas les autres utilisateurs et il vous sera facile de revenir au profil par défaut.

Commencez par ouvrir le menu des Préférences. Pour ce faire, ouvrez le menu principal à l’aide des touches alt-f1. Puis, placez le curseur dans le menu Système à l’aide de la flèche gauche.

Maintenant, sélectionnez l’icône Préférences à l’aide de la flèche bas. Déroulez le sous-menu à l’aide de la flèche droite.

Voici les différents paramètres que vous pouvez régler en utilisant ce menu. Nous vous suggérons de les parcourir avec les flèches de direction, mais de n’en ouvrir aucun pour l’instant :

  • l’apparence de votre bureau, des menus et des fenêtres ;
  • les mises à jour de votre ordinateur, à partir du sous-menu Autre ;
  • votre accès à Internet ;
  • le comportement automatique de votre bureau, à partir du sous-menu Informations personnelles ;
  • le comportement de votre matériel, comme le clavier, l’écran ou la souris.

Ces sous-menu déroulés affichent l’ensemble des réglages disponibles. Pour les lancer, appuyez sur la touche entrée. Les étapes suivantes s'effectuent dans des boîtes de dialogue. Remarquez que les icônes à l’intérieur des sous-menus peuvent varier selon les programmes et le matériel installés sur votre ordinateur.

Notez que quand vous effectuez une modification par ce menu, vous n’avez pas besoin de la confirmer. Elle s’applique automatiquement et instantanément dès que vous la demandez. Certaines options vous permettent donc de prévisualiser ou de tester le résultat avant d’effectuer vos choix.

Les paramètres du menu des préférencesModifier

Dans cette leçon, nous allons vous décrire le détail des icônes qui constituent les sous-menus et vous aurez l’occasion d’effectuer un exercice de réglage des sons.

Exploration de quelques icônesModifier

Votre curseur devrait se trouver dans le menu Préférences du menu Système du menu principal. Pour ce faire, si vous n’y êtes pas déjà, appuyez sur alt-f1 pour ouvrir le menu principal. Ensuite, positionnez votre curseur dans le menu système à l’aide de la flèche gauche et choisissez, à l’intérieur, l’icône Préférences. Déroulez ce sous-menu à l’aide de la flèche droite.

Sélectionnez le menu Apparence et déroulez-le à l’aide de la flèche droite. Dans ce sous-menu, une icône Apparence ouvre une boîte de dialogue permettant de déterminer les propriétés de l’affichage à l'écran. La boîte de dialogue comporte plusieurs fiches identifiées par des onglets. Elles permettent de définir un thème, un fond d’écran, les caractéristiques des polices et un profil d’affichage des icônes. Les fiches Thème et Polices présentent des options intéressantes, particulièrement pour les utilisateurs malvoyants. Pour plus d’informations sur cette boîte de dialogue, reportez-vous à la leçon 3.

Revenez au menu Système avec la flèche gauche, tapée deux fois, et sélectionnez l’icône Administration à l’aide de la flèche bas. Déroulez le sous-menu à l’aide de la flèche droite. La première icône qui apparaît s’intitule : Configuration de l’impression. L’icône Configuration de l’impression sert à installer de nouvelles imprimantes. Lorsque vous la lancez, vous obtenez une série de boîtes de dialogue vous guidant à travers l’installation. Maintenant, déplacez-vous sur l’icône Gestionnaire de paquets en appuyant sur la flèche bas une ou plusieurs fois.

L’icône Gestionnaire de paquets Synaptic lance une boîte de dialogue vous permettant d’installer ou de désinstaller un des programmes fournis avec votre distribution. Une zone de saisie vous permet de rechercher un logiciel par son nom ou sa description. Cet outil ne vous permet pas d’installer d’outils extérieurs, ce qui est une protection contre d’éventuels programmes malveillants. L’installation de programmes hors du catalogue exige des compétences plus avancées. Notez qu’une installation de programme installe l’outil demandé, mais une série d’autres, dont le bon fonctionnement de l’outil sollicité dépend. La récupération du programme s’effectue sur les catalogues en ligne sur Internet ou à partir des DVDs si vous avez demandé la fourniture des DVDs d'installation de votre distribution.

Dans les préférences, vous trouverez également une option Gestionnaire de paramètres Compiz, qui permet aux personnes malvoyantes de configurer certaines fonctions liées aux raccourcis clavier ou au zoom.

l’icône Gestionnaire de paramètres Compiz vous permet de lancer une boîte de dialogue pour modifier des raccourcis clavier ou souris définis par défaut, ou bien figer la taille du grossissement, obtenir l'inversion des couleurs dès le démarrage, etc.

Description de quelques icônes supplémentairesModifier

Maintenant, nous allons poursuivre en commentant les propriétés de quelques paramètres pertinents pour un utilisateur ayant une déficience visuelle.

L’icône Clavier du menu Matériel permet d’ajuster la vitesse de répétition d’un caractère, lorsque vous maintenez une touche enfoncée, et la fréquence de clignotement du curseur. Elle permet également de modifier la langue et le type de clavier utilisé. Enfin, elle permet de définir d'autres modalités de saisie des raccourcis clavier.

L’icône intitulée Date et heure, du menu Administration, permet d’ajuster l’horloge interne de votre système en fonction du fuseau horaire. Rappelez-vous que la date et l’heure peuvent être inscrites dans le tableau de bord.[1]

L’icône Utilisateurs et groupes du menu Administration sert à gérer les mots de passe et les profils utilisateur. Les profils utilisateurs sont très utiles lorsque plusieurs personnes utilisent le même ordinateur. Chacune peut personnaliser son bureau en permanence selon ses préférences (couleurs, contrastes, objets posés sur le bureau, etc). Elle pourra ainsi récupérer ses paramètres de configuration lorsqu’elle saisira son mot de passe à l’ouverture de MATE. L'icône du mot de passe permet de modifier ultérieurement un mot de passe choisi.

L’icône Menu principal du menu Apparence du sous-menu Préférences vous permet d’ajuster les éléments du tableau de bord que vous désirez voir ou ne pas voir, et la forme sous laquelle vous désirez voir les menus.

L’icône Souris du menu Matériel du sous-menu Préférences permet de changer par exemple les gestuelles applicables au pavé tactile d'un ordinateur portable. Ceci peut être utile entre autres pour les personnes malvoyantes qui utilisent une souris. Il est également possible d'inverser le comportement des boutons pour les utilisateurs gauchers. Notez que l’effet des options dépend de votre souris.

L’icône Son du menu Matériel du sous-menu Préférences sert à ajuster les paramètres sonores de votre ordinateur et à activer des avertissements sonores lorsque certains événements arrivent sur votre ordinateur. Il permet par exemple de décider qu’un aboiement retentira à chaque fois que vous essayez d’atteindre l’élément suivant ou précédent alors que vous êtes situé sur le dernier d’une liste. L’activation d’un tel son peut être très utile, car il permet de tester l’état de marche de son ordinateur même si le retour vocal ne fonctionne plus.

Modifier le son d’alerteModifier

Pour modifier le son d’alerte lorsque vous essayez d’aller au-delà des limites d’une fenêtre ou d’une zone de saisie, sélectionnez l'icône Son du menu Matériel du menu Préférences. Appuyez ensuite sur la touche entrée.

La boîte de dialogue Son devrait être ouverte. Par défaut, le curseur se trouve sur une glissière permettant d’ajuster le volume. Appuyez sur la touche tab jusqu’à la liste déroulante intitulée Thème sonore. Par défaut, elle contient deux éléments : Default et Aucun. Vous pouvez donc activer ou ne plus entendre d’alertes. Nous vous recommandons de la laisser en l’état. Appuyez maintenant sur la touche tab.

Ici, vous pouvez sélectionner, à l’aide de la flèche bas, le son qui retentira quand l’alerte se produira. MATE vous offre par défaut cinq sons, d’autres étant possibles. Une fois le son souhaité sélectionné, appuyez sur tab jusqu'au bouton Fermer.[2]

Pour tester votre réglage, appuyez sur alt-f2, puis Retour arrière. Votre son d’alerte devrait retentir.[2]

Si vous désirez apprendre à configurer les paramètres d’affichage, passez maintenant à la leçon 3. Si vous préférez apprendre à régler les paramètres du tableau de bord, passez à la leçon 4.

Configuration de votre écranModifier

Dans cette leçon, vous ferez des exercices à partir de l’icône Apparence du menu Préférences et du gestionnaire de configuration Compiz du menu Préférences que nous explorerons. Cette leçon s’adresse plus particulièrement aux personnes ayant une vision partielle qui voudraient modifier la taille des caractères pour faciliter leur travail.

Réglages de base de l’apparence à partir de raccourcisModifier

De façon temporaire, par exemple pour résoudre une situation particulière ou tester un réglage, vous pouvez modifier à la volée certains éléments d’affichage.

Tout d’abord, vous pouvez ajuster le niveau de zoom à l’écran. Pour ce faire, il vous suffit d’utiliser la touche super et de la combiner avec la roulette de votre souris ou les flèches haut et bas. Le réglage ne sera pas conservé au prochain démarrage, mais vous pouvez ajuster le zoom selon votre convenance. La touche super, appelée aussi touche Windows ou touche Hypra, se trouve à gauche de la touche alt.

À l’intérieur d’une application, comme le navigateur Web ou le traitement de texte, vous pouvez également grossir la taille du contenu, c’est-à-dire de votre document. Pour ce faire, utilisez le raccourci ctrl-la molette de votre souris. Un équivalent de ce raccourci existe également dans le menu Affichage des applications, intitulé Zoom avant ou zoom arrière.

Vous pouvez également choisir de travailler avec l’inversion des couleurs. Pour ce faire, vous utilisez le raccourci touche super-m pour inverser toutes les couleurs de l’écran. Si vous souhaitez limiter l’inversion à la fenêtre, appuyez sur les touches super-n. Nous verrons plus loin comment rendre l’effet de zoom et d’inversion de couleurs permanents.

Enfin, vous pouvez ajuster le niveau de contraste des couleurs de l’écran. Pour ce faire, utilisez le raccourci clavier alt-la molette de la souris.

Choisir des caractéristiques d’affichage de baseModifier

Pour les prochains exercices, nous allons vous guider pour rendre les réglages temporaires effectués au clavier plus définitifs. Pour ce faire, ouvrez le menu principal à l’aide des touches alt-f1. Puis, sélectionnez le menu Système à l’aide de la flèche gauche, puis l’icône Préférences à l’aide de la flèche bas. Déroulez son sous-menu à l’aide de la flèche droite, puis le sous-menu Apparence à l’aide de la même touche. Appuyez sur entrée pour ouvrir la boîte de dialogue.

La boîte de dialogue Préférence de l’apparence comporte une fiche intitulée Thème. Un thème est un modèle de base d’affichage. La fiche Thèmes vous permet de sélectionner les couleurs de l’apparence d’après des modèles de couleurs préconfigurés. Elle offre également la possibilité de personnaliser l’aspect de plusieurs éléments graphiques, concernant la taille des caractères, la couleur et la police. Par exemple, vous pouvez choisir une couleur pour les bordures de fenêtres et les icônes.

Dans la fiche Thèmes, sélectionnez maintenant la liste déroulante de la liste des thèmes et consultez-la en appuyant sur les flèches de direction, ceux-ci étant répartis sur toute la surface de l'écran. MATE propose plusieurs modèles comprenant de forts contrastes. Vous apercevez chaque modèle dès que vous le sélectionnez.

Pour chaque thème, vous pouvez activer un bouton, à l’aide de la touche tab, pour personnaliser ses éléments graphiques. Vous allez maintenant faire l’exercice de changer la couleur et la taille du pointeur pour le thème des contrastes élevés.

Tout d’abord, dans la liste déroulante des thèmes, sélectionnez le thème qui vous convient, pour notre exemple contraste élevé. Ensuite, à l’aide de la touche tab, sélectionnez le bouton Personnaliser et appuyez sur la touche entrée. Une nouvelle boîte de dialogue s’ouvrira.

La boîte de dialogue Personnaliser le thème présente une fiche par élément graphique personnalisable. Nous allons modifier l’apparence du pointeur. Pour ce faire, sélectionnez l’onglet Pointeur de la boîte de dialogue.

La fiche Pointeur présente des listes déroulantes vous permettant de sélectionner un pointeur et sa taille. Changer de pointeur vous permet de modifier sa couleur. Les modèles les plus visibles sont ceux dont le nom commence par comix. Appuyez sur tab pour accéder à la première liste déroulante. Choisissez avec les flèches haut et bas la couleur du pointeur la plus accessible. Vous pouvez choisir une couleur visible selon votre thème. Lorsque vous êtes satisfait, appuyez sur tab pour passer à la liste déroulante suivante.

Maintenant, à l’aide de la souris, sélectionnez la taille la plus adaptée. Lorsque vous êtes satisfait de ce réglage, refaites l’exercice pour les autres fiches et choisissez l’apparence que vous préférez pour les bordures, les icônes et les éléments de contrôle (les bouttons, les zones de saisie, etc).

Souvenez-vous que dès que vous appliquez une propriété, vous pouvez immédiatement voir son résultat à l’écran. Lorsque vous serez satisfait de la configuration du thème, sélectionnez le bouton Fermer de la boîte de dialogue Personnaliser.

Vous pouvez également sélectionner la taille des caractères et le type de la police du texte à l’écran. Pour ce faire, déplacez le curseur sur l’onglet Police. Ici, vous allez pouvoir choisir de modifier la police d’un élément de votre choix, comme celle des applications, des documents, du burau, ou de la barre de titre. Pour choisir un composant, utilisez la touche tab et appuyez sur entrée lorsque vous avez atteint celui qui vous intéresse. Quand vous choisissez un élément, une boîte de dialogue s'ouvre et vous permet d’y choisir le type de police avec les flèches haut et bas, et une zone de saisie, accessible avec tab, vous permet d’entrer la taille souhaitée pour la police sélectionnée. Vous pouvez aussi décider que l'affichage se fasse en gras ou en italique. Là encore, le changement est instantané. Remarquez que les options de la boîte de dialogue Apparence ne s’appliquent pas aux caractères d’un document. Pour modifier les propriétés des caractères utilisés dans un texte par exemple, vous devez utiliser le menu Format de votre application de traitement de texte.

Vous pouvez enregistrer les personnalisations de votre thème sous un nom de votre choix pour y revenir par la suite. Pour ce faire, dans la fiche Thèmes, vous sélectionnez l’option Enregistrer sous avec la touche tab et vous appuyez sur entrée. Une boîte de dialogue s’affichera.

Dans la boîte de dialogue Enregistrer le thème, le curseur se trouve par défaut dans une zone de saisie du nom à donner au nouveau thème. Tapez le nom de votre choix. Puis, à l’aide de la touche tab, entrez, si vous le souhaitez, une description plus explicite pour vous aider à le retrouver. Enfin, cochez les cases pour sauvegarder avec le thème l’arrière-plan et les autres caractéristiques. Sélectionnez ensuite le bouton Enregistrer avec tab et appuyez sur entrée. La boîte de dialogue se refermera.

Le gestionnaire de configuration CompizModifier

MATE vous offre la possibilité de régler des paramètres d'affichage plus avancés, tels que le zoom, l'inversion des couleurs, les filtres, les transparence. Commencez par explorer la fenêtre de dialogue sur la copie d'écran ci-contre pour examiner l'apparence générale de cette boîte de dialogue afin de suivre les prochains exercices(reportez-vous à la page 12 du guide tactile ou branchez le module tactile si vous êtes non voyant). .

la boîte de dialogue de gestion des paramètres Compiz

Lancer le gestionnaire de configuration CompizModifier

Pour lancer le gestionnaire de configuration Compiz, appuyez sur alt-f1 pour ouvrir le menu principal. Choisissez le menu Système et ouvrez le sous-menu des préférences. Enfin, sélctionnez Gestionnaire de paramètres Compiz à l’aide des flèches haut et bas et activez-le avec la touche entrée.

Une boîte de dialogue apparaît pour vous informer du potentiel danger d'utiliser cette application. En effet, si vous modifiez des paramètres de cette boîte de dialogue sans savoir ce que vous faites, vous pourriez rendre très difficile le contrôle de votre bureau à l'aide du clavier ou de la souris. Dans le cadre de cet exercice, appuyez sur la touche entrée pour confirmer l'ouverture de la boîte de dialogue.

Les éléments graphiques du gestionnaire de paramètres CompizModifier

La boîte de dialogue du gestionnaire des paramètres Compiz devrait être ouverte à l'écran. Comme toutes les boîtes de dialogue, elle comporte une barre de titre.

Sous la barre de titre, se trouve une barre de recherche appelée Barre de filtres. Elle vous permet de ne faire apparaître que les options qui contiennent les mots que vous avez saisis. C'est une manière efficace de trouver les options dont vous avez besoin lorsque vous les connaissez à l'avance, plutôt que d'effectuer une recherche dans la fenêtre du gestionnaire de paramètres Compiz.

Sur la gauche de l'écran, se trouvent les catégories qui permettent de classer les différentes options. Compiz parle de modules, ou plugins. En effet, pour chaque catégorie, se trouvent une série de cases à cocher qui permettent d'activer ou de désactiver un des innombrables modules de Compiz, pour remplir des fonctionnalités dépassant de loin celles de la loupe. Compiz permet en effet, outre l'utilisation de la loupe, d'appliquer un grand nombre d'effets visuels esthétiques à différents bureaux, incluant celui MATE, et d'y ajouter certaines fonctionnalités.

Le reste de l'éran est occupé par les cases à cocher. Lorsqu'une case est cochée, d'autres éléments peuvent apparaître, sous forme de boutons voire de fiches dans une sous-boîte de dialogue, permettant de régler les paramètres supplémentaires de la fonctionnalité activée, tels que son comportement ou son raccourci clavier.

En bas de la fenêtre, se trouve le bouton Fermer. Il illustre le fait que, comme pour la boîte de dialogue Apparence, vos réglages ont un effet immédiat sur votre ordinateur.

Appliquer des filtres de couleursModifier

Les filtres de couleurs vous permettent de privilégier l'affichage à l'écran d'une certaine couleur, soit pour améliorer l'aspect général de votre affichage, soit pour éviter de voir certaines couleurs difficiles à distinguer pour vous. Pour activer le filtrage, vous utilisez le raccourci touche super-d. Pour visualiser le résultat des différents filtres, vous utilisez le raccourci ctrl-touche super-s. Comme il existe de nombreux filtres, le prochain exercice va désactiver ceux inutiles pour n'activer que celui qui vous intéresse, afin de vous permettre de basculer entre l'affichage normal et ce filtre plus facilement.

La boîte de dialogue Gestionnaire de paramètres Compiz devrait être ouverte. Positionnez votre curseur dans la zone de recherche, si ce n'est pas déjà fait, et tapez Filtre dans la zone de saisie. Appuyez sur entrée pour lancer la recherche.

Les résultats apparaissant dans la zone des modules, vous allez utiliser les touches maj-tab pour atteindre les résultats. Déplacez votre curseur jusqu'à la case à cocher Filtre de couleurs et appuyez sur la barre d'espace pour activer cette fonctionnalité.

Maintenant, appuyez sur la touche tab pour atteindre le bouton Filtre de couleur, et activez-le à l'aide de la touche entrée.

La fenêtre des paramètres des filtres de couleurs devrait être affichée. Notez qu'elle vous permet notamment de modifier les raccourcis par défaut pour changer de filtre et basculer l'activation de cette fonctionnalité à l'aide du clavier. Dans le cadre de cet exercice, appuyes sur les touches maj-tab jusqu'au bouton Nouveau. Maintenant, appuyez une fois sur maj-tab pour atteindre la liste des filtres.

Vous pouvez parcourir la liste des 20 filtres disponibles à l'aide des flèches haut et bas. Ils sont rangés par ordre alphabétique et c'est dans cet ordre que vous les voyez défiler lorsque vous utilisez le raccourci ctrl-super-s. Pour supprimer des filtres qui ne vous intéressent pas, positionnez votre curseur dessus et appuyez sur la touche supprimer de votre clavier ou activez le bouton Supprimer.

Maintenant, revenez à la liste des filtres avec les touches maj-tab. Pour modifier l'ordre de défilement et d'affichage des filtres, sélectionnez-en un et appuyez sur la touche tab jusqu'au bouton Descendre ou Monter. Vous modifiez ainsi l'ordre des filtres affiché et apparaissant dans votre défilement. Cette possibilité est intéressante si vous ne supprimez pas beaucoup de filtres. La plupart des utilisateurs les supprimeront tous, sauf celui applicable à leur situation.

Quand vous avez terminé de personnaliser vos filtres de couleurs, fermez la fenêtre du gestionnaire de paramètres Compiz à l'aide des touches alt-f4.

Activer définitivement l’inversion des couleursModifier

La fenêtre de gestion des paramètres Compiz devrait être affichée à l'écran.

À l'aide de la touche tab, positionnez votre curseur sur la zone de recherche. Inscrivez-y le mot négatif. Puis appuyez sur la touche entrée.

À l'aide des touches maj-tab, positionnez votre curseur sur le bouton intitulé Négatif et activez-le à l'aide de la touche entrée.

La boîte de dialogue qui s'ouvre n'est pas parfaitement accessible à l'aide d'un lecteur d'écran. Recherchez la case à cocher Basculer automatiquement les fenêtres si vous voulez que l'inversion des couleurs s'active aux prochains démarrages de votre ordinateur.

Maintenant, fermez la boîte de dialogue à l'aide des touches alt-f4.

Ajuster la couleur des fenêtres actives et inactivesModifier

Les utilisateurs malvoyants peuvent avoir intérêt à ce que la fenêtre active, c'est-à-dire celle où se trouve le curseur et où vous travaillez, ait une couleur fortement visible par rapport aux autres fenêtres. Voici comment activer cette fonctionnalité.

La fenêtre de gestion des paramètres Compiz devrait être affichée à l'écran.

À l'aide de la touche tab, positionnez votre curseur sur la zone de recherche. Inscrivez le mot Addhelper et appuyez sur la touche entrée.

À l'aide de la touche maj-tab, positionnez votre curseur sur la case à cocher et activez-la à l'aide de la touche espace. Désormais, les fenêtres qui ne sont pas au premier plan seront grisées, pour que le contraste de leurs bordures soit moins fort et moins gênant pour la vision.

Maintenant, appuyez sur la touche tab pour atteindre le bouton Add Helper et activez-le à l'aide de la touche entrée.

Une nouvelle boîte de dialogue apparaît. Elle comporte deux fiches. La fiche Raccourci clavier permet de définir un raccourci pour désactiver temporairement cette fonctionnalité. La fiche Options diverses vous permet d'ajuster l'ampleur du gris qui cache les fenêtres en arrière-plan. L'ajustement s'opère en modifiant les valeurs dans les zones de saisie pour la fenêtre active et celles en arrière-plan.

Quand vous avez terminé de personnaliser les contrastes des bordures de fenêtres, fermez la fenêtre du gestionnaire de paramètres Compiz à l'aide des touches alt-f4.

Personnaliser le zoomModifier

La fenêtre de gestion des paramètres Compiz devrait être affichée à l'écran.

À l'aide de la touche tab, positionnez votre curseur sur la zone de recherche. Inscrivez-y le mot zoom et validez à l'aide de la touche entrée.

Maintenant, à l'aide des touches maj-tab, sélectionnez le bouton intitulé Zoom du bureau amélioré et activez-le à l'aide de la touche entrée.

La fenêtre de zoom amélioré comporte sept fiches. Tout d'abord, choisissez le facteur de zoom qui devra être appliqué au démarrage de votre ordinateur à l'aide de la fiche Zoom spécifique. Dans cette fiche, modifiez la valeur, de 1 par défaut, qui déterminera votre facteur de zoom.

Maintenant, basculez dans la fiche Suivi focus. Il est important que cette fonctionnalité soit activée, afin que la fenêtre d'agrandissement suive votre curseur lorsque vous le déplacez au clavier. Dans cette fiche, une case à cocher permet de vous assurer que le pointeur de la souris restera au centre de l'écran lorsque vous basculerez entre l'utilisation du clavier et de la souris. Cochez la case Déplacer la zone de zoom instantanément pour que la bascule s'effectue de manière fluide.

Maintenant, dans la fiche Comportement du pointeur, assurez-vous que la case Positionner au centre est cochée. Cette case vous permet de vous assurer que votre pointeur de souris restera en permanence au centre de votre fenêtre de zoom lorsque vous déplacerez votre souris et, en conséquence, la fenêtre du zoom. Elle évite aux utilisateurs malvoyants de rechercher trop fréquemment le pointeur sur l'écran.

Maintenant, dans la fiche Notifications, assurez-vous que la fonctionnalité est activée. Elle vous permet de voir les notifications dès qu'elles apparaissent à l'écran, de manière agrandie.

Enfin, basculez dans la fiche Ajustement. Cette fiche permet d'ajuster la taille de la fenêtre de zoom en fonction du niveau d'agrandissement, en tenant compte du fait que le zoom s'applique à l'ensemble de votre écran.

Notez qu'il existe un autre type de loupe, qui agrandit une zone spécifique de l'écran au lieu de l'écran complet. Cette loupe, qui s'utilise ponctuellement quand vous avez besoin d'agrandir une zone particulière de l'écran, s'intitule le grossisseur. Vous devrez modifier le raccourci par défaut de cet outil, qui rentre en conflit avec celui activant l'inversion des couleurs.

Configuration du tableau de bordModifier

Comme nous l’avons vu au module 1, le tableau de bord affiche des notifications, des lanceurs et les applications actives. Il affiche également le menu principal. Dans cette leçon, nous aborderons les questions relatives à la configuration du tableau de bord, notamment ses propriétés d’affichage, ses lanceurs, le démarrage automatique d’une application et l’ajout d’un programme au menu principal.

Description du tableau de bordModifier

Le tableau de bord, situé par défaut sur le haut de l’écran, peut être déplacé sur les différentes bordures de votre écran et sa taille peut être modifiée. Vous pouvez par exemple le déplacer pour qu’il soit affiché verticalement et le redimensionner pour qu’il soit plus large afin d’afficher plus de boutons. Vous pouvez aussi ajouter des tableaux de bord supplémentaires.

Rappelez-vous que le tableau de bord est accessible en tout temps. Au clavier, vous pouvez y accéder à l’aide des touches alt-ctrl-tab.

Par défaut, MATE présente deux tableaux de bord : celui du haut présentant les applications en cours de travail, et celui du bas présentant les icônes de lancement rapide et le menu principal. Il se peut, surtout si vous êtes aveugle, que votre bureau soit configuré pour avoir ces deux tableaux de bord fusionnés en bas.

Les propriétés du tableau de bordModifier

À partir de la boîte de dialogue des propriétés du tableau de bord, vous pouvez modifier l’apparence du tableau de bord. Voici comment y accéder.

Appuyez sur alt-ctrl-d pour vous assurer que votre curseur est positionné sur le bureau.

Maintenant, appuyez sur alt-ctrl-tab pour atteindre un tableau de bord. À l’aide des touches maj-f10, ouvrez le menu contextuel. À l’aide de la flèche bas, sélectionnez l’icône Propriétés. Appuyez sur la touche entrée pour l’activer. Une nouvelle boîte de dialogue s’ouvrira.

La boîte de dialogue Propriétés du tableau de bord s’affiche. Elle comporte deux onglets. Par défaut, vous êtes sur la fiche intitulée Général. Nous n’explorerons pas, à ce stade, l’autre onglet, qui permet de changer le fond d’écran pour y mettre votre propre illustration. Retenez cependant que cette modification pourrait améliorer votre affichage en plaçant en fond d'écran une image plus obscure ou d'une couleur plus propice à de meilleurs contrastes, si les thèmes proposés ne vous suffisent pas.[3]

La fiche Général offre trois cases à cocher et deux listes déroulantes. Parmi les cases à cocher, une module la fréquence d’affichage du tableau de bord, soit l’option Masquer automatiquement. Si cette case est cochée, cette option cache le tableau de bord lorsqu'il ne sert pas. Pour cocher cette case, appuyez sur la touche Barre d’espacement.

Cette boîte de dialogue n’a pas besoin que vous confirmiez vos choix pour qu’ils s’appliquent. Ils s’opèrent instantanément. C’est pourquoi vous n’avez qu’à taper échap après avoir fait vos choix pour les annuler, ou choisir le bouton Fermer pour les appliquer.

L’ajout de zones de notificationModifier

Sur MATE, vous avez la possibilité d’ajouter au tableau de bord des cases supplémentaires, contenant des informations comme la météo ou l'état des composants de votre ordinateur, ou contenant des fonctionnalités supplémentaires. Par exemple, les personnes malvoyantes peuvent utiliser une fonction de post-it pour faciliter leur prise de notes. Elles peuvent aussi utiliser cette zone pour rajouter un lanceur d'application, le dock, organisant différemment les applications disponibles et celles lancées. Veuillez noter qu'il se peut également que certains types de zones ne soient pas lues par votre lecteur d’écran.

Par défaut, aucune zone de notification autre que les lanceurs, les espaces de travail vus au module 1, leçon 4, les applications actives, les icônes du réseau, de la batterie et du calendrier ne sont affichées. Si vous souhaitez ajouter une zone de notification, positionnez votre curseur sur le tableau de bord à l’aide des touches alt-ctrl-tab après avoir été sur le bureau.

Une fois sur le tableau de bord, à l’aide des touches maj-f10, ouvrez le menu contextuel. Dans ce menu, sélectionnez la commande Ajouter au tableau de bord et appuyez sur Entrée. Une boîte de dialogue s’ouvrira.

La boîte de dialogue Ajouter au tableau de bord devrait être affichée. Il s’agit d’une simple liste d’éléments que vous pouvez ajouter au tableau de bord. Parcourez cette liste à l’aide des flèches haut et bas. Une description est faite pour chaque zone de notification, illustrant le type d’information affiché. Pour valider un ajout, aller jusqu'au bouton Ajouter puis sur le bouton Fermer. La boîte de dialogue se refermera. Notez que la suppression des zones de notification n’est pas possible sans la souris. C’est la raison pour laquelle nous vous invitons à la plus grande prudence afin d’éviter de surcharger le tableau de bord et de le rendre peu intelligible.

Maintenant, pour vérifier que votre nouvelle zone de notification apparaît bien, appuyez sur alt-ctrl-d pour vous rendre sur le bureau et sur alt-ctrl-tab pour atteindre le tableau de bord. Puis, à l’aide de la touche tab, parcourez son contenu. Une zone supplémentaire devrait normalement apparaître si elle est accessible à votre lecteur d’écran.

Le démarrage automatique d’une applicationModifier

Nous allons maintenant vous expliquer la procédure pour que votre système lance automatiquement une application au démarrage de votre session. Pour ce faire, ouvrez le menu principal à l’aide des touches alt-f1. Puis, ouvrez le menu Système avec la flèche gauche.

Sélectionnez l’icône Préférences et déroulez le sous-menu à l’aide de la flèche droite. Sélectionnez l’icône Informations personnelles et déroulez son sous menu.

Maintenant, sélectionnez l’icône Applications au démarrage et appuyez sur entrée. Une boîte de dialogue s’ouvrira.

La boîte de dialogue Applications au démarrage devrait être ouverte. Il s’agit d’un tableau de trois colonnes :

  • une case à cocher pour activer ou non le démarrage de l’application ;
  • la commande lançant l’application ;
  • le nom de l’application.

Une liste d’applications au démarrage est déjà présente. Vous pouvez la consulter à l’aide des flèches de direction, qui vous permettront de prendre connaissance du tableau. Remarquez que votre lecteur d’écran en fait partie.

Au bas de la boîte de dialogue Applications au démarrage, se trouvent plusieurs boutons. Ils sont accessibles avec la touche tab. Sélectionnez Ajouter et appuyez sur entrée. Une nouvelle boîte de dialogue s’ouvrira.

La boîte de dialogue Ajout d'un programme de démarrage devrait être ouverte. Elle comporte deux zones de saisie. La première, où se trouve le curseur par défaut, vous permet de saisir le nom de votre application pour la retrouver plus facilement dans la liste. La seconde, accessible avec la touche tab, vous demande la commande à lancer. Si vous ne la connaissez pas, ou que vous ignorez son chemin d’accès, vous pouvez rechercher l’exécutable avec le bouton Parcourir, accessible avec tab. Appuyez sur entrée, une boîte de dialogue s’ouvrira.

La boîte de dialogue Sélection d'une commande devrait être affichée. Pour saisir directement un chemin, appuyez sur ctrl-l. Dans la zone de saisie, inscrivez : /usr/bin. C’est là que se trouvent tous les exécutables de votre ordinateur.

À l’aide de la flèche bas, faites défiler la liste des exécutables. Sélectionnez par exemple soffice, pour LibreOffice, et appuyez sur entrée. La boîte de dialogue se refermera.

Maintenant, le chemin d’accès à LibreOffice devrait être inscrit dans la zone de saisie Commande. Confirmez votre choix en appuyant sur entrée.

L’application que vous aurez ainsi placée dans la liste Applications au démarrage sera lancée automatiquement à votre prochaine ouverture de session. Pour confirmer, sélectionnez le bouton Fermer de la boîte de dialogue et appuyez sur entrée.

La suppression du démarrage automatique d’une applicationModifier

À partir de la boîte de dialogue Applications au démarrage, vous pouvez également retirer une application des applications au démarrage. Vous allez maintenant retirer l’application LibreOffice des applications au démarrage. Pour ce faire, ouvrez le menu principal à l’aide des touches alt-f1. Puis, ouvrez le menu Système avec la flèche gauche.

Sélectionnez l’icône Préférences et déroulez le sous-menu à l’aide de la flèche droite. Sélectionnez l’icône Informations personnelles et déroulez son sous menu.

Maintenant, sélectionnez l’icône Applications au démarrage et appuyez sur entrée. Une boîte de dialogue s’affiche à l’écran.

Dans la liste des applications au démarrage, sélectionnez soffice à l’aide des flèches de direction. Pour désactiver le démarrage automatique, vous n’avez qu’à décocher la case, située dans la première colonne et accessible à l’aide de la flèche gauche. Pour ce faire, appuyez sur la barre d’espacement. De façon plus radicale et propre, vous pouvez retirer totalement l’application de la liste. Pour ce faire, sélectionnez le bouton Enlever avec la touche tab et activez-le à l’aide de la touche entrée. L’application est aussitôt retirée de la liste.

Maintenant, refermez la boîte de dialogue Applications au démarrage à l’aide du bouton Fermer.

L’ajout d’un lanceur au menu principalModifier

L’ajout d’un lanceur au menu principal aura pour effet d’ajouter une commande dans le menu ou l’un de ses sous-menus. Cette commande peut lancer un programme ou ouvrir un fichier. Il peut donc s’agir d’un exécutable ou d’un raccourci vers un fichier.

Tout d’abord, appuyez sur alt-f1 pour ouvrir le menu principal et appuyez sur la flèche gauche pour ouvrir le menu Système de cette zone de l’écran. Appuyez ensuite sur la touche flèche bas pour dérouler ce menu.

À l’aide de la flèche bas, sélectionnez l’icône Préférences. Appuyez sur la touche flèche droite pour ouvrir le sous-menu. La première commande du sous-menu est Apparence. Appuyez sur flèche droite pour ouvrir le sous-menu.

À l’aide de la touche flèche bas, sélectionnez l’icône Menu principal. Appuyez ensuite sur entrée pour l’ouvrir.

La fenêtre de configuration du menu principal apparaît à l’écran. Dans la colonne de gauche, que vous pouvez parcourir avec les flèches de direction, vous trouvez le nom des catégories du menu principal. À l’aide de la flèche bas, sélectionnez l’option Accessoires. Appuyez sur tab pour voir ce que contient la catégorie.

La partie droite de l’écran, où se trouve maintenant le curseur, se présente comme le tableau de la boîte de dialogue Applications au démarrage. Chaque ligne correspond à une icône de la catégorie. La case à cocher de la première colone permet d’afficher ou pas l’icône. La seconde colonne contient l’icône telle qu’elle apparaît à l’écran.

Tout d’abord, dans la partie gauche de la fenêtre, choisissez l’endroit où vous désirez ajouter le programme ou le raccourci, c’est-à-dire la catégorie. Dans le cadre de cet exercice, nous allons en créer une nouvelle. Choisissez d'abord celle couvrant le menu Système à l'aide de la flèche bas.

Maintenant, à l'aide de la touche tab, sélectionnez le bouton Nouveau menu et appuyez sur entrée pour ouvrir la boîte de dialogue.

La boîte de dialogue Propriétés du répertoire devrait être affichée à l'écran. Votre curseur se trouve dans une zone de saisie dans laquelle vous pouvez inscrire le nom de la nouvelle catégorie. Dans le cadre de cet exercice, entrez le nom Formation. Appuyez sur entrée pour confirmer la création de la nouvelle catégorie du menu Système.

De retour dans la boîte de dialogue de personnalisation du menu principal, positionnez votre curseur sur le menu formation et appuyez sur tab pour basculer sur la partie droite de la boîte de dialogue. La zone est vide, puisque vous n'y avez encore pas inscrit d'icônes de lancement. Elle ne sera donc pas affichée dans le menu principal.

Maintenant, à l’aide de la touche tab, sélectionnez l’icône Nouvel élément et appuyez sur la barre d’espacement. Une nouvelle boîte de dialogue s’affiche à l'écran. Notez que la touche Entrée ferme la boîte de dialogue car elle correspond au bouton Valider.

La boîte de dialogue Créer un lanceur devrait être affichée. Tout d'abord, vous allez déterminer si votre lanceur est un raccourci de lancement d'une application ou un lien vers un site Internet. Pour e faire, à l'aide de la touche tab, déplacez votre curseur sur la liste déroulante intitulée Type. Puis, avec la flèche bas, choisissez entre Application et emplacement. Dans le cadre de cet exercice, sélectionnez Emplacement.

Maintenant, avec la touche tab, revenez à la zone de saisie intitulée Nom. Inscrivez le nom du programme tel que vous désirez le voir apparaître dans le menu principal, par exemple, Pouvoir accéder et utiliser MATE. Puis, appuyez sur tab.

Dans la zone de saisie Emplacement, inscrivez l'adresse menant au présent livre, à savoir https://fr.wikibooks.org/wiki/Pouvoir_Acc%C3%A9der_et_Utiliser_MATE

Si vous aviez choisi d'ajouter un lanceur d'application, vous auriez pu taper le chemin d’accès et le nom du programme pour lequel vous voulez créer un lanceur dans le menu principal. Par exemple, ~/Bureau. Dans ce cas, la boîte de dialogue affiche un bouton Parcourir, qui vous permet de rechercher le programme sur votre ordinateur.

Enfin, confirmez votre choix en sélectionnant, avec tab ou maj-tab, le bouton Valider. Vous aurez ainsi ajouté le lanceur pour ouvrir ce tutoriel à la nouvelle rubrique Formation du menu Système du menu principal. Notez que vous pouvez, dans cette fenêtre, aller beaucoup plus loin, en renommant les catégories, réorganisant leur contenu, créant une arborescence entièrement personnalisée. Nous vous conseillons de valider chaque changement dont vous êtes sûr et de les tester, afin de pouvoir les supprimer plus facilement, voire à l'aide du bouton Rétablir de la boîte de dialogue.

Maintenant, refermez la boîte de dialogue Menu principal. Pour cela, sélectionnez le bouton Fermer à l’aide de la touche tab et appuyez sur entrée.

Questions et réponsesModifier

Cette leçon propose un quiz de cinq questions à choix multiples. Les réponses sont dans la section Réponses au quiz. Pour plus d'interaction, se trouve dans cette zone la raison pour laquelle les autres réponses ne sont pas correctes.

Questions à choix multiplesModifier

  1. Par quel menu du menu principal s’effectuent les opérations de configuration ?
    1. Le menu Applications
    2. Le menu Système
    3. Le menu Emplacement
    4. Le menu Outils système
  2. Quel menu affecte les paramètres de tout l'ordinateur et non ceux spécifiques à votre session ?
    1. Le menu des préférences
    2. Le menu Administration
    3. Le menu Informations personnelles du menu Préférences
    4. Le menu Apparence
  3. Quelle est l’icône du menu principal qui permet d’installer des programmes ?
    1. Le gestionnaire d’impression
    2. Le gestionnaire de paramètres Compiz
    3. Le gestionnaire de paquets Synaptic
    4. L'outil Utilisateurs et groupes
  4. Quel est le raccourci clavier permettant d’inverser les couleurs de tout l’écran ?
    1. Touche super-m
    2. Touche super-n
    3. Touche super-k
    4. alt-ctrl-m
  5. Quelle est la commande qui vous permet d’ajouter un lanceur au menu principal ?
    1. Nouvelle rubrique, du menu principal
    2. Nouvel élément, du menu principal
    3. Nouveau séparateur, du menu principal
    4. La partie droite du menu principal

Réponses au quizModifier

  1. Réponse 2. Le menu Applications permet de lancer des programmes installés sur votre ordinateur, le menu Emplacement permet d’accéder rapidement à des endroits précis de votre système. Outils système est une catégorie du menu Logiciels contenant des outils de visualisation et d’accès expert au fonctionnement de votre ordinateur.
  2. Réponse 2. La commande Informations personnelles ou Apparence du menu Préférences n’affecte que votre session et n'est pas un menu, les préférences modifient vos paramètres de l'utilisateur.
  3. Réponse 3. Les autres icônes permettent d’ajouter une imprimante et de gérer des paramètres d’affichage ou de l'ordinateur.
  4. Réponse 1. Le raccourci clavier touche super-n ne permet d’inverser les couleurs que des fenêtres. Le raccourci super-k active une aide au repérage de la souris.
  5. Réponse 2. Nouvelle rubrique permet d’ajouter une catégorie. La partie droite du menu principal du menu Préférences permet d’activer ou non l’affichage d’un élément, sans supprimer le lanceur. La commande Nouveau séparateur crée un menu dans le menu principal.

Notes et référencesModifier

  1. ins-t : permet d’obtenir l’heure. Cette commande vous permet d’obtenir l’heure en tout temps sans quitter l’application dans laquelle vous travaillez.
  2. 2,0 et 2,1 ctrl : permet d’interrompre la parole d’Orca. Cette commande permet d’interrompre la parole de votre synthèse vocale, et ce à n’importe quel moment.
  3. insertion-entrée du pavé numérique : permet d’obtenir le titre de la fenêtre d’application. Cette commande permet de lire le titre de l’application dans laquelle vous vous trouvez et le nom du document dans lequel vous travaillez. Notez que dans une boîte de dialogue, cette commande vous permet également de lire le titre de la boîte ou de l’onglet ou de la fiche active.