Différences entre les versions de « Apache/Sécurité »

<IfModule mod_authz_core.c>
<RequireAny>
Require all denied
Require ip 127.0.0.1
Require ip 127.0.0.2
=== whitelist avec allow (obsolète en Apache 2.4) ===
 
<source lang="apache">
<Directory /usr/share/phpmyadmin/>
<IfModule mod_access_compat.c>
;<code>order allow, deny</code> : commence par les autorisation puis démarre les interdictions au risque d'interdire ce qui était autorisé.
;<code>order deny, allow</code> : le contraire est moins restrictif.
 
=== blacklist avec Require<ref>https://httpd.apache.org/docs/2.4/fr/upgrading.html</ref> ===
<source lang="apache">
<Directory /usr/share/phpmyadmin/>
<IfModule mod_authz_core.c>
Require all granted
Require not ip 127.0.0.1
</IfModule>
</Directory>
</source>
 
=== blacklist avec deny (obsolète en Apache 2.4) ===
<source lang="apache">
<Directory /usr/share/phpmyadmin/>
<IfModule mod_access_compat.c>
order allow,deny
allow from all
deny from 127.0.0.1
</IfModule>
</Directory>
</source>
 
== Protection par mot de passe ==